[webkit-reviews] review granted: [Bug 17261] IconRecord::loadImageFromResource is not called for urlIcon : [Attachment 19763] Allow the urlIcon to be themable on some ports

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jun 8 18:05:30 PDT 2008


Darin Adler <darin at apple.com> has granted Holger Freyther
<freyther at handhelds.org>'s request for review:
Bug 17261: IconRecord::loadImageFromResource is not called for urlIcon
http://bugs.webkit.org/show_bug.cgi?id=17261

Attachment 19763: Allow the urlIcon to be themable on some ports
http://bugs.webkit.org/attachment.cgi?id=19763&action=edit

------- Additional Comments from Darin Adler <darin at apple.com>
I think the #if could be done better. The default icon data could go inside the
if statement. The only line that needs to be different is the
setImageData/loadImageFromResource line.

To make it clear that the tradeoff here is faster load time vs. themability, I
think the #if should be named something like CAN_THEME_URL_ICON and be defined
at the top of IconDatabase.cpp.

    #if PLATFORM(QT)
    #define CAN_THEME_URL_ICON
    #endif

Then later:

    #ifdef CAN_THEME_URL_ICON 

Or something along those lines.

r=me, as-is


More information about the webkit-reviews mailing list