[webkit-reviews] review denied: [Bug 14998] Full page zooming support : [Attachment 16529] Update to reflect WebKitGtk -> WebKit name change

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Oct 7 16:15:04 PDT 2007


Adam Roben <aroben at apple.com> has denied Holger Freyther
<freyther at handhelds.org>'s request for review:
Bug 14998: Full page zooming support
http://bugs.webkit.org/show_bug.cgi?id=14998

Attachment 16529: Update to reflect WebKitGtk -> WebKit name change
http://bugs.webkit.org/attachment.cgi?id=16529&action=edit

------- Additional Comments from Adam Roben <aroben at apple.com>
-	 IntPoint translatePoint(const IntPoint&) const;
+	 IntRect translateRect(const IntRect&) const;

I don't think translateRect is a good name for this method, since it both
translates and scales. A better name might be transformRect.

+    WebKitPage* page = WEBKIT_PAGE(containingWindow());
+    WebKitPagePrivate* pageData = WEBKIT_PAGE_GET_PRIVATE(page);

This code (in ScrollViewGtk.cpp) is unused. We also should not be using WebKit
types within WebCore.

+    double scaleFactor = frameView->frame()->page()->scaleFactor();

There are a number of places where the result of Frame::page() is being used
without a null-check. This is in general an unsafe thing to do.

r- given the above and Darin's comments. I think Darin gave some really good
suggestions about how to improve the design of this feature.



More information about the webkit-reviews mailing list