[webkit-reviews] review granted: [Bug 14774] Submitted data only includes first input item : [Attachment 18198] proposed fix

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Dec 30 22:35:02 PST 2007

Darin Adler <darin at apple.com> has granted Alexey Proskuryakov <ap at webkit.org>'s
request for review:
Bug 14774: Submitted data only includes first input item

Attachment 18198: proposed fix

------- Additional Comments from Darin Adler <darin at apple.com>
Will this work if you submit the same form multiple times?

mailtoForm is not a great name for a boolean; it sounds like it's a form. Maybe
isMailtoForm would be a better name? I guess it's not your name.

     bool mailtoForm = u.protocol() == "mailto";

This one is case sensitive, but the new code is correctly folding case.

I'm not happy that this code still has to use DeprecatedString even in this
line of code:

+		 data = new FormData((DeprecatedString("body=") +
encodeCString(body.latin1())).replace('+', "%20").latin1());

Isn't there a way to do this without DeprecatedString and without widening and


More information about the webkit-reviews mailing list