[webkit-reviews] review granted: [Bug 10353] XMLSerializer and DOMParser should have real implementations : [Attachment 9989] Patch

bugzilla-request-daemon at opendarwin.org bugzilla-request-daemon at opendarwin.org
Sat Aug 12 16:14:58 PDT 2006

Darin Adler <darin at apple.com> has granted Darin Adler <darin at apple.com>'s
request for review:
Bug 10353: XMLSerializer and DOMParser should have real implementations

Attachment 9989: Patch

------- Additional Comments from Darin Adler <darin at apple.com>
In DOMParser::parseFromString:

+	 return doc;

it would be slightly more efficient if this said return doc.release().

Also, I think it would be cleaner to have am early return if the contentType is
no good rather than having the whole function be inside an if statement.

DOMParser.h does not need to include PlatformString.h. Instead it should just
forward declare String as it does Document. I think the parameters of
parseFromString should be named since it's not clear from their type alone what
they are.

Same for XMLSerializer.h -- it can also forward-declare String, but the
parameter does not need a name in that case.

These are all nitpicks, it's OK to land this as-is.


More information about the webkit-reviews mailing list