[webkit-qt] API review, comments needed!

Simon Hausmann simon.hausmann at nokia.com
Fri Mar 5 07:16:37 PST 2010


Hi,

we just went through the diff of the header files between Qt 4.6's WebKit and 
the trunk. It's a relatively small diff, but nevertheless taking another look 
at it revealed a few interesting issues. Here are the comments and questions 
we collected. Please comment :)


QWebFrame::scrollRecursively:

    * Implicit dependency on last mouse move event is bad. The position should 
become an explicit function parameter.

    * The use of "recursion" in the name is confusing, it suggests recursive 
behaviour to child frames. However the behaviour is to continue scrolling the 
parent frames.

    * The documentation does not explain what the return value is.

    * The auto test only checks successful scrolling. It never tests the case 
of the function
      returning false.

QWebSettings:

    * The following hunk causes binary compatibility issues:

         LocalContentCanAccessRemoteUrls,
-        DnsPrefetchEnabled
+        LocalContentCanAccessFileUrls,
+        DnsPrefetchEnabled,

      because the values of the enum changed.

   * The default values of the settings are not documented!

   * The documentation for the XSSAuditorEnabled feature is missing a pointer 
to a more detailed
     explanation of the WebKit Cross Site Auditing feature.

   * Should it be XSSAudit_ing_Enabled?



Simon
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.webkit.org/pipermail/webkit-qt/attachments/20100305/48b7e427/attachment.bin>


More information about the webkit-qt mailing list