[webkit-help] need help - run-webkit-app doesn't work for me

Sitao Yang sitao_yang at apple.com
Thu Oct 13 12:34:47 PDT 2016

Hi Ryosuke,

I figured out the issue. You were correct that it has to do with System Integrity Protection introduced in El Capitan. After temporally disable it, everything just worked. 

Thanks a lot for your help.


Sitao Yang  Apple Inc. | Customer Systems | sitao at apple.com <mailto:sitao_yang at apple.com> | 650.787.6692

> On Oct 11, 2016, at 5:06 PM, Sitao Yang <sitao_yang at apple.com> wrote:
> Hi Ryosuke,
> Thank you for your response. 
> I followed your instructions and checked my WebKit app in Activity Monitor, it showed it’s still using the system’s WebKit framework instead of my local one.
> Also, I’m running on macOS Sierra (16A323). So the mentioned issue with El Capitan shouldn’t matter to me. I’d have made it clear in my initial email. 
> Thanks,
> —Sitao
>> On Oct 11, 2016, at 3:56 PM, Ryosuke Niwa <rniwa at webkit.org <mailto:rniwa at webkit.org>> wrote:
>> On Tue, Oct 11, 2016 at 12:02 PM, Sitao Yang <sitao_yang at apple.com <mailto:sitao_yang at apple.com>> wrote:
>>> Hi there,
>>> I tried to test a WebKit app (written in Cocoa) using WebKit framework I
>>> built locally to verify a bug I reported earlier and was told that it has
>>> been fixed. For some reason it didn’t work. Here’s what I did.
>>> 1. Download the latest WebKit source code from
>>> git://git.webkit.org/WebKit.git <git://git.webkit.org/WebKit.git> (origin/master branch)
>>> 2. Check few files and confirm that the fix is included in the source code
>>> 3. Run build-webkit script to build WebKit framework, which is successful.
>>> 4. Run run-webkit-app with my WebKit app as the parameter
>>> I can still replicate the reported bug. I suspect that run-webkit-app is not
>>> using my locally built WebKit framework. I have 2 questions:
>>> 1. Is there a simply way to tell which WebKit framework my running WebKit
>>> app is linked to?
>> Open Activity Monitor, double click on your process, and open "Open
>> Files and Ports".  The locally built WebKit frameworks should show up
>> there.
>>> 2. If it turns out that it is still linked to the WebKit framework in
>>> /System/Libraries folder, how can I change it to link to my locally built
>>> WebKit framework?
>> I don't know which OS X / macOS you're using but perhaps you want to
>> take a look at https://trac.webkit.org/wiki/WebKitNightlyElCapWorkaround <https://trac.webkit.org/wiki/WebKitNightlyElCapWorkaround>
>> and related pages.
>> - R. Niwa
>> _______________________________________________
>> webkit-help mailing list
>> webkit-help at lists.webkit.org <mailto:webkit-help at lists.webkit.org>
>> https://lists.webkit.org/mailman/listinfo/webkit-help
> _______________________________________________
> webkit-help mailing list
> webkit-help at lists.webkit.org
> https://lists.webkit.org/mailman/listinfo/webkit-help

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-help/attachments/20161013/6026d849/attachment.html>

More information about the webkit-help mailing list