[webkit-help] First time trying to compile WebKit on Ubuntu -- not going well

Patrick Chkoreff patrick at rayservers.net
Sun Mar 2 10:32:01 PST 2014

Osztrogonác Csaba wrote, On 03/02/2014 01:11 PM:

> I suggest you should use at least Ubuntu 12.10 instead of 12.04.
> Because on 12.04 the default GCC is 4.6 which isn't enough nowadays,
> you need at least 4.7 version. ...

Right about gcc 4.7, and as I mentioned in my reply to Zan, I already
upgraded to 4.7 last night.

> And there isn't official libtiff5-dev
> package on 12.04 which is needed for update-webkitgtk-libs script.

Ah. Well.  That sounds pretty definitive then.  Guess I'll upgrade to
Ubuntu 12.10 as you say.

> On 12.10 it's so easy to build WebKitGTK+:
> - Tools/gtk/install-dependencies
> - Tools/Scripts/update-webkitgtk-libs
> - Tools/Scripts/build-webkit --gtk

Right, and thanks for your 05 Dec 2012 email about that:


OK, Ossy and Zan, here's my next step.  I'll go ahead and update to
Ubuntu 12.10 first, since that sounds like a pretty definite
requirement.  Then, if I still have problems building, I'll try
upgrading to gcc/g++ 4.8.  (I may do that anyway, after trying the 12.10
thing first.)

> Ossy

Thank, you Ossy.

-- Patrick

More information about the webkit-help mailing list