[webkit-help] Library not found for -lWebKitSystemInterfaceSnowLeopard

Alan Burnett ralanburnett at hotmail.com
Wed Jun 23 15:31:20 PDT 2010


I ran into this problem before, but forgot how I solved it.

When building WebKit using WebKit.xcodeproj I get the following error:

Library not found for -lWebKitSystemInterfaceSnowLeopard

I can't recall whether I changed the library name in the build profile to WebKitSystemInterfaceSnowLeopard.a or what I did to get the compiler to find the library.  Any help would be appreciated.

This brings up another issue, and I appreciate all the help provided by everyone - the WebKit mailing lists provide great insight.

I imagine I am in the minority here, but I like to build my WebKit modules in Xcode.  However, every time I download a new nightly build I have to jump through a number of hoops (not always the same ones) to get one or more of JavaScriptCore, WebCore, and WebKit to build via Xcode (and yes, I build them in the correct order).  I am now comfortable with having to update the locations of missing JavaScriptCore and WebCore frameworks (this is now expected), but the missing library isn't has obvious for me to solve.

Here is my request.  Since JavaScriptCore, WebCore, and WebKit are they most important components of a build (via Xcode), couldn't someone update the corresponding .xcodeprojs JavaScriptCore, WebCore, and WebKit to reflect the updated file structure with the nightly build?  Please?  This also happens with many of the ancillary .xcodeprojs as well, but people build those way less frequently.  I also would like to add an updating of DumpRenderTree.xcodeproj as well :)


The New Busy is not the old busy. Search, chat and e-mail from your inbox.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-help/attachments/20100623/66ad48fe/attachment-0001.html>

More information about the webkit-help mailing list