[webkit-help] Windows build errors (CFLite_debug.lib not found and more)

Alexander Shulgin alexander.shulgin at yessoftware.com
Fri Jul 30 02:53:44 PDT 2010

On 29.07.2010 20:25, Hochmuth, Roland M wrote:
> Hi Alex, I tried your suggestion below regarding downloading the
> requirements.zip file. That got be a bit further. Thanks! Unfortunately,
> I’m still not completely up and running, but some projects are building.
> There were several Resource files, such as JavaScriptCore.rx,
> WebKit2.rc, WebProcess.rc that I needed to modify. Several strings, such
> as __VERSION_MAJOR__, that were used to define other values were not
> defined. I ended up hard-coding for FILE_VERSION, PRODUCTVERSION.
> Several files required “cairo.h” which was in
> “requirements/include/cario”. I added this directory in addition to the
> include path “requirements/include” that you mentioned below.
> In WinLauncher I needed to change a compiler option from treat compiler
> warning as errors to treat as warning.
> Right now everything in JavaScriptCore is building.
> I’m still running into problems with a bunch of projects. For example,
> in WebCore Folder QTMovieWin fails with
> ------ Build started: Project: QTMovieWin, Configuration: Debug Win32 ------

I get something like 'this project not selected for build with this 
solution configuration' and everything builds correctly.

I'm using a trunk rev circa 57800, not updated in quite a while.

> WebCore and WebKit built. However, WebKit2Generated and WebCoreGenerated
> failed. There are also some files in WebKitTools that are failing with
> the same error as above. I did not run dos2unix on any files as the
> error above doesn’t seem to match what was described on the webkit WEB
> pages.
> It seems like I’m still missing a step in the configuration to get
> everything built. If you or anyone has any additional suggestions that
> would be great.

I remember there was the need to convert line endings in auxiliary shell 
scripts to make them run correctly with cygwin.  Here's the command I've 
used for that purpose:

find . \( -name \*.sh -o -name \*.in \) -print0 | xargs -0 sed -i.bak -e 

Hope this helps.


More information about the webkit-help mailing list