[webkit-help] Building in AIX using xlC compiler

Pankaj Jangid pankaj.jangid at gmail.com
Tue Jan 26 21:53:49 PST 2010

The issue is resolved. Note the file name in the last line containing (I)
message immediately after the (S) message. #include the undefined class's
header file in the noted file.


On Thu, Jan 14, 2010 at 8:11 PM, Pankaj Jangid <pankaj.jangid at gmail.com>wrote:

> Hi,
> I am building on AIX using xlC compiler. I am making changes to the code
> where ever required but now I am stuck at a point for which no solution is
> found searching around.
> The errors comes when compiling JavaScriptCore/API/JSBase.cpp. One of the
> error is,
> "./wtf/RefPtrHashMap.h", line 205.5: 1540-1174 (S) The member "template
> pair<HashMap<RefPtr<T>,U,V,W,X>::iterator,bool> inlineAdd(const KeyType &,
> const MappedType &)" is not declared as a template in its containing class
> definition.
> And similar 5 more similar errors for methods, overloaded inlineAdd(),
> set(), add().
> The error is coming because while compiling JSBase.cpp. It is ultimately
> dependent on SymbolTable.h and SymbolTable.h is instantiating HashMap
> template using some JSC:: classes (UString etc.) which are still not
> declared.
> Have anybody seen this error on AIX and have anybody tried to resolve this
> issue earlier?
> --
> Regards
> Pankaj
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-help/attachments/20100127/bf2c022c/attachment-0001.html>

More information about the webkit-help mailing list