[webkit-help] Building in AIX using xlC compiler

Pankaj Jangid pankaj.jangid at gmail.com
Thu Jan 14 06:41:18 PST 2010


I am building on AIX using xlC compiler. I am making changes to the code
where ever required but now I am stuck at a point for which no solution is
found searching around.

The errors comes when compiling JavaScriptCore/API/JSBase.cpp. One of the
error is,

"./wtf/RefPtrHashMap.h", line 205.5: 1540-1174 (S) The member "template
pair<HashMap<RefPtr<T>,U,V,W,X>::iterator,bool> inlineAdd(const KeyType &,
const MappedType &)" is not declared as a template in its containing class

And similar 5 more similar errors for methods, overloaded inlineAdd(),
set(), add().

The error is coming because while compiling JSBase.cpp. It is ultimately
dependent on SymbolTable.h and SymbolTable.h is instantiating HashMap
template using some JSC:: classes (UString etc.) which are still not

Have anybody seen this error on AIX and have anybody tried to resolve this
issue earlier?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-help/attachments/20100114/2d887e01/attachment.html>

More information about the webkit-help mailing list