[webkit-gtk] Crash on xLarge memory allocation with webkitgtk+ 2.8.3

Mario Sanchez Prada mario at webkit.org
Thu Jun 25 08:58:44 PDT 2015

On 25/06/15 16:48, Carlos Alberto Lopez Perez wrote:
> [...] 
> 2.8.X includes the bmalloc memory allocator by default, while on 2.6.X
> the default allocator was tcmalloc (IIRC).
Yes, I've seen that. It seems that tcmalloc is no longer available, though:

> I have seen a similar behaviour, when bmalloc fails to allocate memory
> it returns NULL and causes a crash on the webprocess.

Thanks for sharing this. It's good to know I'm not the only one seeing this.
Btw, I forgot to mention before that this system I'm working on is a 32-bit
(Linux) one. Not sure that could have anything to do, though.

> You may want to try to build with -DUSE_SYSTEM_MALLOC=ON but I don't
> think it will fix your problem. You will probably get an OOM situation
> instead of a crash.

Yes, that's one of the first things I've tried, but I still get the crash
using the system allocator. I'm still trying to debug this, but the fact
that is a 32bit system is making debugging a bit more painful than usual.


More information about the webkit-gtk mailing list