[webkit-gtk] Build webkit in ubuntu. Error after executing make

Abhimanyu Panwar panwar.abh at gmail.com
Tue May 14 12:16:32 PDT 2013

Hi Guys,

I am trying to install WebKitgtk+ on Ubuntu 13.04 according to
http://trac.webkit.org/wiki/BuildingGtk.  I follow these steps
1.  Get source code from
      $svn checkout https://svn.webkit.org/repository/webkit/trunk WebKit

2    $ Tools/gtk/install-dependencies
3    $ Tools/Scripts/update-webkitgtk-libs
4    $ Tools/Scripts/build-webkit --gtk            >---the build is successful.

But when I type:
$ sudo make install
make: *** No rule to make target `install'.  Stop.

Then I ran $ make distclean.

I found another webpage providing instructions to build webkit
https://help.ubuntu.com/community/WebKit. I configured  the source using

./autogen.sh --prefix=/usr

 It ran successfully.

But when I run $make  it gives

CXXLD  Programs/WebKitPluginProcess
  CXX    Source/WebKit2/gtk/Programs_WebKitWebProcess-MainGtk.o

  CXXLD  Programs/WebKitWebProcess
./.libs/libwebkit2gtk-3.0.so: undefined reference to `soup_session_request_uri'
collect2: error: ld returned 1 exit status
make[1]: *** [Programs/WebKitWebProcess] Error 1

make[1]: Leaving directory `/home/panwar/WebKit'
make: *** [all] Error 2

I could not find any help about this on web. I am very new to this.
But hopefully my next

 1 year of education will be based on webkit and accessing render
trees and manipulating
 it according to our algorithms. Any help will be highly appreciated.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-gtk/attachments/20130514/1ab38571/attachment-0001.html>

More information about the webkit-gtk mailing list