[webkit-gtk] Building Webkit-GTK in Fedora 18 alpha

Edwin Lim limed3 at gmail.com
Fri Nov 2 22:30:15 PDT 2012

Thanks very much for the tip Joanie.

I hadn't thought about changing the linker and spent most of my time
banging my head on my desk while looking through the packages and bug
reports. It scares me to think the things I might have done if you hadn't
emailed this...

But regardless, the linker not being Gold looks like it was the issue.
Thanks again for the tip!

Edwin Lim

On Fri, Nov 2, 2012 at 3:10 PM, Joanmarie Diggs <jdiggs at igalia.com> wrote:

> On 10/29/2012 11:20 PM, Edwin Lim wrote:
> [...]
> >    CXXLD    Libwebkit2gtk-3.0.1a
> >    CCLD     Programs/unittests/testapplicationscache
> > /lib64/libxslt.so: undefined reference to 'xmlBufUse'
> > /lib64/libxslt.so: undefined reference to 'xmlBufContent'
> > collect2: error: ld returned 1 exit status
> > make[1]: *** [Programs/unittests/testapplicationcache] Error 1
> > make[1]: *** Waiting for unfinished jobs....
> I ran up against this today. It was driving me insane because I have two
> F18 boxes configured (afaik) more or less identically. In both cases I
> was using the build-webkit script, after having done
> update-webkitgtk-libs to be sure I was using the expected versions of
> the build dependencies. On one box the build worked, on the other it
> failed. :-/
> After much hair-pulling and help from Martin, I finally found the
> difference: the linker. I thought I was using Gold on both boxes; I
> wasn't. Switching to Gold on the failing box made the build work.
> HTH and good luck!
> --joanie
> _______________________________________________
> webkit-gtk mailing list
> webkit-gtk at lists.webkit.org
> http://lists.webkit.org/mailman/listinfo/webkit-gtk
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-gtk/attachments/20121103/bc754d89/attachment.html>

More information about the webkit-gtk mailing list