[webkit-gtk] Building Webkit-GTK in Fedora 18 alpha

Joanmarie Diggs jdiggs at igalia.com
Fri Nov 2 12:10:53 PDT 2012

On 10/29/2012 11:20 PM, Edwin Lim wrote:


>    CXXLD    Libwebkit2gtk-3.0.1a
>    CCLD     Programs/unittests/testapplicationscache
> /lib64/libxslt.so: undefined reference to 'xmlBufUse'
> /lib64/libxslt.so: undefined reference to 'xmlBufContent'
> collect2: error: ld returned 1 exit status
> make[1]: *** [Programs/unittests/testapplicationcache] Error 1
> make[1]: *** Waiting for unfinished jobs....

I ran up against this today. It was driving me insane because I have two
F18 boxes configured (afaik) more or less identically. In both cases I
was using the build-webkit script, after having done
update-webkitgtk-libs to be sure I was using the expected versions of
the build dependencies. On one box the build worked, on the other it
failed. :-/

After much hair-pulling and help from Martin, I finally found the
difference: the linker. I thought I was using Gold on both boxes; I
wasn't. Switching to Gold on the failing box made the build work.

HTH and good luck!

More information about the webkit-gtk mailing list