[webkit-gtk] webkitgtk-1.8.x and Java/Flash plugins

Daniel Drake dsd at laptop.org
Wed May 2 09:20:10 PDT 2012


I'm running webkitgtk-1.8.1 on Fedora 17. I have both the GTK2 and
GTK3 versions installed.

In Epiphany, which is GTK3, Flash (Adobe) and Java (icedtea-web) don't work :(

I downloaded the webkitgtk-1.8.1 source code, and then I compiled the
GtkLauncher demo.

First I tried with gtk3:

# gcc main.c $(pkg-config --cflags --libs gtk+-3.0 webkitgtk-3.0)
# ./a.out
Java and Flash do not work here. Java applets comes up as a "?", flash
appears as a blank space. Tested with:


Now I try the GTK2 version.
# gcc -DGTK_API_VERSION_2 main.c $(pkg-config --cflags --libs gtk+-2.0
# ./a.out

Flash and Java now work!

Is this because flash and java plugins link against GTK2, which
obviously won't work under a GTK3 environment?
I know there has been work to split the plugins into another process,
but is this available in webkitgtk-1.8.0, or is it only for v1.9.0 and

I tried using Sun's java plugin loosely following the instructions here:
It works on both GTK2 and GTK3 GtkLauncher. The plugin doesn't link
against any version of GTK.


More information about the webkit-gtk mailing list