[webkit-gtk] hovering-over-link signal and HitTestResult in WebKit2 API

Carlos Garcia Campos cgarcia at igalia.com
Thu Feb 2 10:25:05 PST 2012

El jue, 02-02-2012 a las 09:35 -0800, Martin Robinson escribió:
> I have no answer for why the WebCore name is mouseDidMoveOverElement.
> Perhaps we could ask. Note that I'm not saying that we must absolutely
> use the name HitTest. I think we should just avoid names like Element,
> Node, and Document.

Ok, I understand Element can be confusing, but I still think
HitTestResult sounds like the result of a HitTest. In both cases,
hovering-whatever signal and context menu, it will be used to give
context to the user about the thing affected, so I thin the name should
be consistent with both. For example, CursorTargetInformation or
WebKitMouseTarget, as you proposed in previous mails, might not be
accurate either for a context menu triggered with the keyboard. So I
would rather use a generic name that could be used in both cases, but I
can't think of any . . . 

> --Martin

Carlos Garcia Campos
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.webkit.org/pipermail/webkit-gtk/attachments/20120202/ef373436/attachment-0001.bin>

More information about the webkit-gtk mailing list