[webkit-efl] Naming rules for setting APIs

Grzegorz Czajkowski g.czajkowski at samsung.com
Wed Oct 10 05:16:50 PDT 2012


IMHO Kubo's suggestion is the strongest. If we approve this convention what
will happen for the current API, for both wk1 and wk2? As I result:
1) should we change WK1 API (ewk_view.h) as it doesn't follow this rule?
2) for WK2 we can land patch Jinwoo's patch
3) spelling API should be adjusted - ewk_text_checker_settings.h. I will
take of it.


-----Original Message-----
From: webkit-efl-bounces at lists.webkit.org
[mailto:webkit-efl-bounces at lists.webkit.org] On Behalf Of Raphael Kubo da
Sent: 10 October 2012 13:43
To: webkit-efl at lists.webkit.org
Subject: Re: [webkit-efl] Naming rules for setting APIs

"Michal G." <guziemic.spam at gmail.com> writes:

> Hi,
> If I can add something to discussion, from API user perspective I 
> prefer such naming convention
> ewk_settings_enable_frame_flattening_set
> then
> ewk_settings_frame_flattening_enabled_set

It makes sense if you come from a, let's say, sane library background

For some reason, the EFL themselves use this Yoda-like convention for their
calls, so we should probably follow that as well.

Intel Finland Oy
Registered Address: PL 281, 00181 Helsinki Business Identity Code: 0357606 -
4 Domiciled in Helsinki

webkit-efl mailing list
webkit-efl at lists.webkit.org

More information about the webkit-efl mailing list