[webkit-efl] Naming rules for setting APIs

Raphael Kubo da Costa rakuco at webkit.org
Wed Oct 10 04:42:50 PDT 2012

"Michal G." <guziemic.spam at gmail.com> writes:

> Hi,
> If I can add something to discussion, from API user perspective I
> prefer such naming convention
> ewk_settings_enable_frame_flattening_set
> then
> ewk_settings_frame_flattening_enabled_set

It makes sense if you come from a, let's say, sane library background

For some reason, the EFL themselves use this Yoda-like convention for
their calls, so we should probably follow that as well.

Intel Finland Oy
Registered Address: PL 281, 00181 Helsinki
Business Identity Code: 0357606 - 4
Domiciled in Helsinki

More information about the webkit-efl mailing list