[webkit-efl] HEADS-UP: ewk_view_setting_scripts_window_open_{get, set} have been renamed

Raphael Kubo da Costa kubo at profusion.mobi
Tue Nov 1 06:20:29 PDT 2011

Hey there.

After SVN commit 98908, the ewk_view_setting_scripts_window_open_*
family of functions has been renamed.

 - ewk_view_setting_scripts_window_open_get is now
 - ewk_view_setting_scripts_window_open_set is now

Since r93833 we had the API in a weird state where the calls to
(dis)allow scripts to close windows did not match the naming scheme of
the calls to (dis)allow scripts to open windows, which was pretty weird.

The naming scheme of the former made much more sense, so I've chosen to
adapt the latter, older functions.

Raphael Kubo da Costa
ProFUSION embedded systems

More information about the webkit-efl mailing list