[webkit-dev] Watch out for std::optional's move constructor
rniwa at webkit.org
Tue Dec 18 12:31:10 PST 2018
On Tue, Dec 18, 2018 at 11:35 AM Michael Catanzaro <mcatanzaro at igalia.com>
> I know I'm getting a bit far afield here, but:
> On Mon, Dec 17, 2018 at 9:26 PM, Ryosuke Niwa <rniwa at webkit.org> wrote:
> > But then our behavior of HashMap which doesn't accept the POD
> > integral value of 0 as a key
> This behavior is really unexpected and dangerous , and we should
> seriously consider changing it. No doubt lots of bugs caused by this
> are just waiting to be uncovered. I've been working on WebKit since
> 2014 and didn't know about this until last month.
I tend to agree but then we'd come up with other numbers for the empty &
I've been thinking that we could use -1 and -2 but that's also somewhat
Another oddity: I recently learned that AtomicStrings are actually
> interned strings. WTF. Why not call them that? I had thought for years
> that they were strings safe to be shared across threads, like other
> atomics. Not at all. Maybe this was dumb of me, but it could have been
> avoided by better naming.
This topic has been discussed extensively in the past:
- R. Niwa
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev