[webkit-dev] When should I use AtomicString vs String?
darin at apple.com
Sat Jun 1 15:58:44 PDT 2013
On May 31, 2013, at 8:01 PM, Glenn Adams <glenn at skynav.com> wrote:
> One thing that always threw me was the term "Atomic" in the class name. I wonder if the term "InternedString" would make it usage more apparent.
I personally love the name AtomicString (the string of tomorrow) and have been using that name for it for the past 10 years, but I see that InternedString is what this would be called in Java and .NET context so I guess we could change to help people familiar with those.
More information about the webkit-dev