[webkit-dev] Unified source builds: A new rule for static variables
keith_miller at apple.com
Tue Aug 29 17:30:49 PDT 2017
In addition to what Darin said, I think using a consistent name makes the most sense. If “<Filename>Internal” is what we would use for some of the places we should use it everywhere.
> On Aug 29, 2017, at 5:29 PM, Darin Adler <darin at apple.com> wrote:
>> On Aug 29, 2017, at 4:32 PM, Ryosuke Niwa <rniwa at webkit.org <mailto:rniwa at webkit.org>> wrote:
>> It's probably more appropriate to use <Filename>Static for files like Editing.cpp, which is a collection of a bunch of global functions.
> The keyword “static” is being used to ask for what C++ calls “internal linkage” <http://en.cppreference.com/w/cpp/language/storage_duration <http://en.cppreference.com/w/cpp/language/storage_duration>>.
> So we could even consider “internal” in those cases, unless we can come up with even better words.
> — Darin
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev