[webkit-dev] Terminology for giving up ownership: take, release, move

Michael Catanzaro mcatanzaro at igalia.com
Tue Sep 6 12:04:34 PDT 2016

On Tue, 2016-09-06 at 11:12 -0700, Filip Pizlo wrote:
> FWIW, I still like release() better than move().  a = move(b) is a
> command to the system to move b to a.  So, value =
> collection.move(key) feels like a command to the collection to move
> key to value, which is clearly not what is going on.

I agree that move() would be quite confusing; I think we should avoid
this option.


More information about the webkit-dev mailing list