[webkit-dev] Should overridden methods use 'virtual' keyword in addition to 'override'?

Konstantin Tokarev annulen at yandex.ru
Fri Mar 4 06:54:56 PST 2016

04.03.2016, 17:53, "Michael Catanzaro" <mcatanzaro at igalia.com>:
> On Thu, 2016-03-03 at 11:38 -0800, Geoffrey Garen wrote:
>>  I volunteer for any future needs in the physical restraint department
>>  -- but in this case, I think (3) sounds like a good idea.
> Allowing Darin to perform (3) sounds good to me, what could possibly go
> wrong? Some folks will have to rebase patches, but that should not be
> difficult....
> We could also really go the full mile and start using override wherever
> possible. I guess a script to make that change could be written by
> turning on the GCC -Wsuggest-override warning, and parsing the compiler
> output to get line numbers that need fixed....

clang-modernize can do that automatically, I have WebCore patch ready for upload.


More information about the webkit-dev mailing list