[webkit-dev] PSA: WTF::move has been renamed to WTFMove

Anders Carlsson andersca at apple.com
Mon Jan 4 08:39:16 PST 2016

Hi Andy,

see my comment in the bug.

- Anders

> On Jan 2, 2016, at 2:28 AM, Andy Estes <aestes at apple.com> wrote:
> Hi folks,
> As of <http://trac.webkit.org/changeset/194496>, WTF::move has been removed and replaced with a macro named WTFMove. This allows us to take advantage of some new warnings in clang while still retaining the checks provided by WTF::move. More details can be found in <https://bugs.webkit.org/show_bug.cgi?id=152601>.
> Happy new year!
> Andy
> _______________________________________________
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> https://lists.webkit.org/mailman/listinfo/webkit-dev

More information about the webkit-dev mailing list