[webkit-dev] Type checking / casting helpers

Yong Li yong.li.webkit at outlook.com
Thu Oct 2 19:02:19 PDT 2014

Downcast is the old good name.

"cast" is so vague. I would assume cast<A>(B) means: { return (A)B; }

Yong Li
From: Darin Adler<mailto:darin at apple.com>
Sent: ‎10/‎3/‎2014 3:16 AM
To: WebKit Development<mailto:webkit-dev at lists.webkit.org>
Subject: Re: [webkit-dev] Type checking / casting helpers

I suggested the name; my inspiration was the boost::polymorphic_downcast function template. I also like the way a name ending with the word cast fits in with the family of static_cast, dynamic_cast, and reinterpret_cast.

— Darin
webkit-dev mailing list
webkit-dev at lists.webkit.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-dev/attachments/20141003/72f47764/attachment.html>

More information about the webkit-dev mailing list