[webkit-dev] Type checking / casting helpers

Darin Adler darin at apple.com
Thu Oct 2 17:17:02 PDT 2014

I suggested the name; my inspiration was the boost::polymorphic_downcast function template. I also like the way a name ending with the word cast fits in with the family of static_cast, dynamic_cast, and reinterpret_cast.

— Darin

More information about the webkit-dev mailing list