[webkit-dev] size_t vs unsigned in WTF::Vector API ?
ap at webkit.org
Thu Nov 20 14:06:44 PST 2014
SmallVector and Vector seem reasonable to me. I think that this is the right nomenclature - using limited size vectors should be a conscious choice.
Even SmallVector should probably have a size_t API, so that we could centralize magnitude checks. What do you think?
20 нояб. 2014 г., в 11:40, Filip Pizlo <fpizlo at apple.com> написал(а):
> That looks like a pretty good performance win.
> I'd advocate for SmallVector and Vector, then.
>> On Nov 20, 2014, at 11:38 AM, Chris Dumez <cdumez at apple.com> wrote:
>> The corresponding Blink bug did contain some performance data:
>> Chris Dumez - Apple Inc.
>> Cupertino, CA
>>> On Nov 20, 2014, at 11:32 AM, Geoffrey Garen <ggaren at apple.com> wrote:
>>>> I wonder what the downsides are to this approach. Footprint of Vector?
>>> It looks like the original change was motivated by shrinking Vector:
>>> Sadly, it didn’t include any data on the observed benefit :(.
>>> webkit-dev mailing list
>>> webkit-dev at lists.webkit.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev