[webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo
mitz at apple.com
Wed Jun 19 09:41:55 PDT 2013
On Jun 19, 2013, at 7:37 PM, Timothy Hatcher <timothy at apple.com> wrote:
> What about?
> StyleResolver* existingStyleResolver()
> StyleResolver& styleResolver()
I like it.
> — Timothy Hatcher
> On Jun 19, 2013, at 11:49 AM, Balazs Kelemen <kbalazs at webkit.org> wrote:
>> For me optional seems very misleading and generally different prefixes suggests that those objects are not the same.
>> Maybe IfExists does not sound nicely but at least it's clear. I would choose to have a pointer version with IfExists and a reference version which is a noun, like:
>> StyleResolver* styleResolverIfExists()
>> StyleResolver& styleResolver()
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
More information about the webkit-dev