[webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

Simon Fraser simon.fraser at apple.com
Tue Jun 18 19:20:19 PDT 2013

On Jun 18, 2013, at 7:11 PM, Darin Adler <darin at apple.com> wrote:

> On Jun 18, 2013, at 7:05 PM, Ryosuke Niwa <rniwa at webkit.org> wrote:
>> Why don't we call it requireStyleResolver() instead?
> I’m warming to this idea. Maybe we can use “require” as a term of art, analogous to the way we use “create”, to mean “create if not already created”.

Since the fact that it returns a reference implies that it must create something if necessary, the “required” part of the name seems redundant. Why not just
	StyleResolver& styleResolver()

requireStyleResolver() sounds like it would return a bool.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20130618/1b961fb8/attachment.html>

More information about the webkit-dev mailing list