[webkit-dev] When should I use AtomicString vs String?
mjs at apple.com
Sat Jun 1 16:45:02 PDT 2013
On Jun 1, 2013, at 3:58 PM, Darin Adler <darin at apple.com> wrote:
> On May 31, 2013, at 8:01 PM, Glenn Adams <glenn at skynav.com> wrote:
>> One thing that always threw me was the term "Atomic" in the class name. I wonder if the term "InternedString" would make it usage more apparent.
> I personally love the name AtomicString (the string of tomorrow) and have been using that name for it for the past 10 years, but I see that InternedString is what this would be called in Java and .NET context so I guess we could change to help people familiar with those.
If we were to change the name, I'd go with Symbol or Atom. But I think AtomicString is a fine name and I don't think InternedString is better. All plausible names I can think of are jargon that you have to learn the first time if you don't know it.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev