[webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo
bjonesbe at adobe.com
Wed Jul 3 20:05:39 PDT 2013
On Jul 2, 2013, at 17:06, "Maciej Stachowiak" <mjs at apple.com<mailto:mjs at apple.com>> wrote:
On Jul 1, 2013, at 7:31 PM, Brady Eidson <beidson at apple.com<mailto:beidson at apple.com>> wrote:
On Jul 1, 2013, at 5:27 PM, Ryosuke Niwa <rniwa at webkit.org<mailto:rniwa at webkit.org>> wrote:
I concur. Maybe
I concur with this.
For this entire discussion, this is where I was hoping it was headed.
I like. Maybe we should use this naming pattern and type signature even when only one or the other variant exists?
FWIW, I like this as well. I also like the idea of being consistent with this style even when only one exists. Is there a good reason why we wouldn't want to do that? I can only think of benefits.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev