[webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo
mjs at apple.com
Tue Jul 2 17:05:38 PDT 2013
On Jul 1, 2013, at 7:31 PM, Brady Eidson <beidson at apple.com> wrote:
> On Jul 1, 2013, at 5:27 PM, Ryosuke Niwa <rniwa at webkit.org> wrote:
>> I concur. Maybe
>> StyleResolver* styleResolverIfExists()
>> StyleResolver& styleResolver()
> I concur with this.
> For this entire discussion, this is where I was hoping it was headed.
I like. Maybe we should use this naming pattern and type signature even when only one or the other variant exists?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev