[webkit-dev] Int/FloatPoint and Int/FloatSize

Simon Fraser simon.fraser at apple.com
Wed Jan 9 16:39:47 PST 2013

On Jan 9, 2013, at 3:47 PM, Steve Block <steveblock at chromium.org> wrote:

>> Also, the word "position" is used to represent a tree-position in DOM in
>> WebKit so please don't use that to represent a point in a screen or a layout
>> coordinate system.
> OK, perhaps we should use Vector2d, as is used by the Chromium port

I don't like that name. I'm really not sure that this set of changes is going in the right direction. What's driving them; some abstract sense of purity, or reducing the chances of introducing real bugs that we've seen in the past?


More information about the webkit-dev mailing list