[webkit-dev] Windows Build Broken?

Rakesh Sadhu rakeshsadhu at hotmail.com
Fri Aug 2 01:29:20 PDT 2013

Hi Brent,Thanks for the suggestion , however i found out my mistake , and build is ready .
But I am facing one more  problem , my release winlauncher launches properly whereas debug winlauncher fails with the message "Failed to determine path to AAS Directory".
In the file DLLLauncherMain.cpp ::moidfypath 
//#if defined(_M_X64)    static const wstring pathPrefix = L"C:\\Program Files\\Common Files\\Apple\\Apple Application Support";//#else   // static const wstring pathPrefix = L"C:\\Program Files (x86)\\Common Files\\Apple\\Apple Application Support";//#endif
I commented above lines , but i was encountering another problem " msvcr80.dll" missing .

So is it like , my windows somehow got corrupted and i need to redo all or is there any work around for this .

Subject: Re: [webkit-dev] Windows Build Broken?
From: bfulgham at apple.com
Date: Thu, 1 Aug 2013 09:50:11 -0700
CC: mital.d.vora at gmail.com; webkit-dev at lists.webkit.org
To: rakeshsadhu at hotmail.com

Please review your build log.  The problem is the following:
"fatal error C1083: Cannot open include file: 'd3dx9.h': No such file or directory”
You do not have the DirectX SDK installed, as documented in Step 4 of http://www.webkit.org/building/tools.html.

On Aug 1, 2013, at 1:46 AM, Rakesh Sadhu <rakeshsadhu at hotmail.com> wrote:Hi ,I couldn't fix the problem  with vs2005.Now I am trying to build with vs2010 and it fails too.here is the pasebin link : http://pastebin.com/W0YyGXZGKindly guide.


Date: Tue, 23 Jul 2013 07:21:23 +0530
Subject: Re: [webkit-dev] Windows Build Broken?
From: mital.d.vora at gmail.com
To: rakeshsadhu at hotmail.com
CC: webkit-dev at lists.webkit.org

Sorry Its not exactly the same error. but Its similar error which is present in build-webkit

I am trying to build using Visual Studio 2010 Express using commandline cygwin toolsThanks,

Mital Vora.

On Tue, Jul 23, 2013 at 7:17 AM, Mital Vora <mital.d.vora at gmail.com> wrote:
For the WinCairo Build as well these are the exact errors coming in the buildbot
Building results into: /cygdrive/c/Projects/BuildSlave/win-cairo-release/build/WebKitBuild
WEBKIT_OUTPUTDIR is set to: C:\Projects\BuildSlave\win-cairo-release\build\WebKitBuild
Use of uninitialized value in print at /cygdrive/c/Projects/BuildSlave/win-cairo-release/build/Tools/Scripts/webkitdirs.pm line 1644.

Windows and WinCairo Build from commandline seems broken.. can anybody help fixing this.Regards,

Mital Vora.

On Sun, Jul 21, 2013 at 9:07 PM, Rakesh Sadhu <rakeshsadhu at hotmail.com> wrote:
Hi ,I updated my webkit source code and tried to build it on windows machine , and it fails to compile, with following error
Tools/Scripts/build-webkit --debug
Installing WebKitSupportLibrary...The WebKitSupportLibrary has been sucessfully installed in /home/rsadhu/trunk/WebKitLibraries/win*************************************************************Cannot find '/cygdrive/c/Program Files (x86)/Microsoft Visual Studio 10.0/Common7/IDE/VCExpress.exe'Please execute the file 'vcvars32.bat' from'C:\Program Files (x86)\Microsoft Visual Studio 8\VC\bin\'to setup the necessary environment variables.*************************************************************Died at /home/rsadhu/trunk/Tools/Scripts/webkitdirs.pm line 1627.

Any Pointers on this?

webkit-dev mailing list
webkit-dev at lists.webkit.org

webkit-dev mailing list
webkit-dev at lists.webkit.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20130802/7a41ab86/attachment.html>

More information about the webkit-dev mailing list