[webkit-dev] ScrollableArea::scrollSize() vs ScrollableArea::maximumScrollPosition()

Xianzhu Wang wangxianzhu at chromium.org
Mon Apr 1 14:47:22 PDT 2013


ScrollableArea::scrollSize() and ScrollableArea::maximumScrollPosition()
seem to return the same value if the parameters of the scrollbars are
updated. Can we remove one of them?

I think the benefits are:
- no redundancy;
- ScrollableArea could be independent on scrollbars;
- maximumScrollPosition() is more up-to-date without the need of
- the ambiguity of the name scrollSize (e.g. RenderLayer::m_scrollSize and
RenderLayer::scrollSize() are totally different things) can be eliminated

What do you think? Am I missing anything?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20130401/188d416d/attachment.html>

More information about the webkit-dev mailing list