[webkit-dev] New Feature: Canvas Path object

Rik Cabanier cabanier at gmail.com
Mon Sep 24 12:03:03 PDT 2012

On Mon, Sep 24, 2012 at 10:27 AM, Darin Adler <darin at apple.com> wrote:

> On Sep 22, 2012, at 9:21 PM, Elliott Sprehn <esprehn at chromium.org> wrote:
> > On Fri, Sep 21, 2012 at 6:34 AM, Dirk Schulze <dschulze at adobe.com>
> wrote:
> >
> >> I would like to ask if there are objections to implement the canvas
> Path object.
> >
> > Do we have metrics on how often people already have things named Path?
> All other canvas objects have a prefix like CanvasGradient and
> CanvasPattern, this thing seems inconsistent and more likely to break
> existing pages.
> Dirk, given the fact that you quite logically referred to this as “the
> canvas Path object” when mentioning it to us, and the fact that both
> CanvasGradient and CanvasPattern objects exist, CanvasPath sure does seem
> like a nice name for this. Someone should make that suggestion on the
> WebApps mailing list!
A difference though is that the path object doesn't have to be associated
with a canvas. It is/will be useful with other features such as SVG as well.
I feel uneasy with the generic name too; maybe a DOM/HTML/JS prefix is
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20120924/9b72ca11/attachment.html>

More information about the webkit-dev mailing list