[webkit-dev] LayoutTestHelper

Dirk Pranke dpranke at chromium.org
Thu May 3 09:35:52 PDT 2012

On Thu, May 3, 2012 at 9:16 AM, Maciej Stachowiak <mjs at apple.com> wrote:
> On May 3, 2012, at 8:54 AM, Dirk Pranke <dpranke at chromium.org> wrote:
>> On Thu, May 3, 2012 at 7:35 AM, Maciej Stachowiak <mjs at apple.com> wrote:
>>> Better naming/documentation may help. But I think the root problem here was
>>> that the Chromium Android LayoutTestHelper does not exist in the WebKit
>>> repository, as far as I can tell. So there was no reasonable way for anyone
>>> to consider it when making changes.
>> I'm not trying to make a big deal out of this, but the python code for
>> the android port is checked in :)
>> http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/layout_tests/port/chromium_android.py
> I see, I was looking for something that would start a LayoutTestHelper tool. It seems like Android has a different interpretation of what start_helper means. I would like to fix all this stuff but I am not sure how to fix the naming. Do you have a suggestion for a better name for the port-specific pre-test setup hook?

As I mentioned earlier in the thread, there is now a setup_test_run()
hook as well in the Port interface (and a clean_up_test_run() hook) --
you can see examples of use in
Tools/Scripts/webkitpy/layout_tests/port/gtk.py -- so we could
probably move the android code to that and then change the name or at
least the doc string of start_helper to be clear that it's

-- Dirk

More information about the webkit-dev mailing list