[webkit-dev] Unprefixing Blob.webkitSlice() ?
darin at chromium.org
Sun Jun 10 23:34:34 PDT 2012
Happy to see us support unprefixed too. With other vendors on board, it
seems like a straightforward addition to the platform.
I'm not sure if you are proposing to also remove the prefixed form. I'm
not sure what it would take to remove the prefixed version. We'd need some
way to know when it is safe to remove it. We could surely instrument the
code to measure its use relative to the unprefixed form once it is widely
On Sun, Jun 10, 2012 at 11:17 PM, Kinuko Yasuda <kinuko at chromium.org> wrote:
> Hi WebKit folks,
> We've been vendor-prefixing Blob.slice() since we changed the semantics of
> slice() to make it alike Array.slice, i.e. from "start, length" to "start,
> end" semantics in r83873 . The non-prefixed version had only been
> shipped in Chrome and must have helped apps migrate into the new semantics.
> However Mozilla has now unprefixed it since Gecko/FireFox 13.0 , Opera
> said they are going to unprefix it with the new semantics  and IE
> compatibility test has a set of Blob.slice tests which require unprefixed
> slice .
> Maybe it's becoming a good time to unprefix slice() again?
>  http://trac.webkit.org/changeset/83873
>  https://bugs.webkit.org/show_bug.cgi?id=78111
>  http://samples.msdn.microsoft.com/ietestcenter/#fileapi
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev