[webkit-dev] Unprefixing Blob.webkitSlice() ?
kinuko at chromium.org
Sun Jun 10 23:17:12 PDT 2012
Hi WebKit folks,
We've been vendor-prefixing Blob.slice() since we changed the semantics of
slice() to make it alike Array.slice, i.e. from "start, length" to "start,
end" semantics in r83873 . The non-prefixed version had only been
shipped in Chrome and must have helped apps migrate into the new semantics.
However Mozilla has now unprefixed it since Gecko/FireFox 13.0 , Opera
said they are going to unprefix it with the new semantics  and IE
compatibility test has a set of Blob.slice tests which require unprefixed
Maybe it's becoming a good time to unprefix slice() again?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev