[webkit-dev] Should we move methods from layoutTestController/etc... to internals?

Maciej Stachowiak mjs at apple.com
Tue Feb 21 15:14:48 PST 2012

On Feb 21, 2012, at 1:21 PM, Ryosuke Niwa wrote:

> I'd prefer getting rid of the entire interface when possible. We're obviously removing layoutTestController, textInputController, etc... at the moment though.

I think it's helpful to organize the methods by functional area instead of dumping them all onto one giant interface. layoutTestController for example has far too many methods, in my opinion. We would not design a public API where every method is on one global interface, and our testing API should not look that way either. I would like to see our test API split up more, rather than combined into a single interface.

I'm also confused about your examples of interfaces you are "obviously" removing. Did you mean "obviously not removing"? I ask because layoutTestController has at least some methods that fundamentally have to deal with DRT, not just WebCore; and textInputController is something you gave as an example of methods that use WebKit-level functionality and so cannot move to WebCore. Can you clarify?


More information about the webkit-dev mailing list