[webkit-dev] webkit-dev [check-webkit-style - shows warnings on the untouched code in repo]

David Levin levin at chromium.org
Tue Sep 27 23:02:57 PDT 2011


If you run check-webkit-style on a file, it will show all style issues for
the whole file.

However, you can run it on a diff (which is what webkit-patch upload will
do). Then it will only flag lines that you changed.

It still may flag issues that you didn't cause but you changed those lines,
so it is recommended to fix the style issues on those lines (and on no other
lines) unless it would cause a lot of other lines to change (like
unindenting a whole section of code).

Hope that helps!
dave


On Tue, Sep 27, 2011 at 10:59 PM, Kishore Ganesh
<kbolisetty at innominds.com>wrote:

> Hi All,****
>
> We Have a patch to upload for the bug id : 39986.****
>
> The changes are in RenderTable.cpp and RenderTableSection.cpp.****
>
> When we run check-webkit-style on each of these files, It shows few errors
> that are not related to our patch. Can some suggest,****
>
> **·         **If anyone has already seen such behaviour & ****
>
> **·         **If we can ignore these Or we need to cleanup all the
> warnings though its not related to the fix for 39986?****
>
> Here is the output from the script…****
>
> ** **
>
> $ Tools/Scripts/check-webkit-style Source/WebCore/rendering/RenderTable.cpp
> ****
>
> Source/WebCore/rendering/RenderTable.cpp:36:  Alphabetical sorting
> problem.  [bu****
>
> ild/include_order] [4]****
>
> Source/WebCore/rendering/RenderTable.cpp:89:  Should have only a single
> space af****
>
> ter a punctuation in a comment.  [whitespace/comments] [5]****
>
> Source/WebCore/rendering/RenderTable.cpp:141:  A case label should not be
> indent****
>
> ed, but line up with its switch statement.  [whitespace/indent] [4]****
>
> Source/WebCore/rendering/RenderTable.cpp:145:  One line control clauses
> should n****
>
> ot use braces.  [whitespace/braces] [4]****
>
> Source/WebCore/rendering/RenderTable.cpp:1092:  An else statement can be
> removed****
>
> when the prior "if" concludes with a return, break, continue or goto
> statement.****
>
>   [readability/control_flow] [4]****
>
> ** **
>
> $ Tools/Scripts/check-webkit-style
> Source/WebCore/rendering/RenderTableSection.****
>
> cpp****
>
> Source/WebCore/rendering/RenderTableSection.cpp:27:  You should add a blank
> line****
>
> after implementation file's own header.  [build/include_order] [4]****
>
> Source/WebCore/rendering/RenderTableSection.cpp:216:  Boolean expressions
> that s****
>
> pan multiple lines should have their operators on the left side of the line
> inst****
>
> ead of the right side.  [whitespace/operators] [4]****
>
> ** **
>
> Regards,****
>
> Kishore****
>
> _______________________________________________
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20110927/a176d8ac/attachment.html>


More information about the webkit-dev mailing list