[webkit-dev] Change to style guideline: should use type& instead of type* for out arguments
darin at apple.com
Tue Oct 4 20:34:38 PDT 2011
On Oct 4, 2011, at 6:14 PM, Eric Seidel wrote:
> I thought historical policy was universally against the word "get" in function names.
The policy has been to reserve the word get to mean a function that gets a value in an out argument, as opposed to a function that returns a value, which we instead name with a noun or adjective describing the value.
> I guess you're suggesting that "get" should only be applied to function names which have an out-argument?
Right, that’s what we’ve been doing. But I see now that the rule is not as well known as I thought.
More information about the webkit-dev