[webkit-dev] Incremental steps towards moving WebCore/platform out of WebCore
jmason at rim.com
Thu Dec 15 06:59:08 PST 2011
The BlackBerry port uses BlackBerry::Platform for its system libraries - it wouldn't surprise me if some of our files in the platform dirs have "using BlackBerry" so they can just use "Platform::symbol" instead of "BlackBerry::Platform::symbol" in the source. Shouldn't be hard to sort out, though.
> -----Original Message-----
> From: webkit-dev-bounces at lists.webkit.org [mailto:webkit-dev-
> bounces at lists.webkit.org] On Behalf Of Hajime Morrita
> Sent: Thursday, December 15, 2011 3:31 AM
> To: Jarred Nicholls
> Cc: webkit-dev at lists.webkit.org
> Subject: Re: [webkit-dev] Incremental steps towards moving
> WebCore/platform out of WebCore
> One concern is that "Platform" is too generic to put in global
> namespace and it might conflict existing symbols from platform SDK or
> something. But because we already have generic names like ASSERT() and
> it works, this concern is just a theoretical thing.
> So if it works with existing platforms, I think it's fine.
> On Thu, Dec 15, 2011 at 4:02 PM, Jarred Nicholls <jarred at webkit.org>
> > On Thu, Dec 15, 2011 at 1:55 AM, Adam Barth <abarth at webkit.org>
> >> I was working backwards from what's going to be needed to move
> >> WebCore/platform out of WebCore, and it occurred to me that we'll
> >> probably want a separate namespace for the code once it's outside of
> >> WebCore, just like WTF has a separate namespace from JSC.
> >> It seems like introducing the new namespace before the move would be
> >> beneficial because it would help us sort out whatever layering
> >> violations we have today (as they'd become apparent because of the
> >> explicit mention of the WebCore namespace).
> >> What would be an appropriate name for the namespace? My first
> >> instinct is "Platform" to match the name of the new directory, but
> >> open to suggestions.
> > I think Platform is good. When explaining it to an outsider, I refer
> to it
> > as the Client Interface or Port Interface. If Platform doesn't
> > well with everyone then maybe something around that verbiage would
> fit. But
> > honestly I can't think of anything better than Platform.
> >> Adam
> >> _______________________________________________
> >> webkit-dev mailing list
> >> webkit-dev at lists.webkit.org
> >> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
> > _______________________________________________
> > webkit-dev mailing list
> > webkit-dev at lists.webkit.org
> > http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.
More information about the webkit-dev