[webkit-dev] Incremental steps towards moving WebCore/platform out of WebCore
jarred at webkit.org
Wed Dec 14 23:02:46 PST 2011
On Thu, Dec 15, 2011 at 1:55 AM, Adam Barth <abarth at webkit.org> wrote:
> I was working backwards from what's going to be needed to move
> WebCore/platform out of WebCore, and it occurred to me that we'll
> probably want a separate namespace for the code once it's outside of
> WebCore, just like WTF has a separate namespace from JSC.
> It seems like introducing the new namespace before the move would be
> beneficial because it would help us sort out whatever layering
> violations we have today (as they'd become apparent because of the
> explicit mention of the WebCore namespace).
> What would be an appropriate name for the namespace? My first
> instinct is "Platform" to match the name of the new directory, but I'm
> open to suggestions.
I think Platform is good. When explaining it to an outsider, I refer to it
as the Client Interface or Port Interface. If Platform doesn't resonate
well with everyone then maybe something around that verbiage would fit.
But honestly I can't think of anything better than Platform.
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev