[webkit-dev] Incremental steps towards moving WebCore/platform out of WebCore

Adam Barth abarth at webkit.org
Wed Dec 14 22:55:00 PST 2011

I was working backwards from what's going to be needed to move
WebCore/platform out of WebCore, and it occurred to me that we'll
probably want a separate namespace for the code once it's outside of
WebCore, just like WTF has a separate namespace from JSC.

It seems like introducing the new namespace before the move would be
beneficial because it would help us sort out whatever layering
violations we have today (as they'd become apparent because of the
explicit mention of the WebCore namespace).

What would be an appropriate name for the namespace?  My first
instinct is "Platform" to match the name of the new directory, but I'm
open to suggestions.


More information about the webkit-dev mailing list