[webkit-dev] A proposal for "Platform Mechanisms"

Mike Marchywka marchywka at hotmail.com
Sat Jun 19 09:34:00 PDT 2010

> From: jpetso at gmx.at
> To: webkit-dev at lists.webkit.org
> Date: Sat, 19 Jun 2010 11:35:28 -0400
> Subject: Re: [webkit-dev] A proposal for "Platform Mechanisms"
> On June 18, 2010, Anders Carlsson wrote:
>> On Jun 17, 2010, at 2:04 PM, Jeremy Orlow wrote:
>>> Overall, looks great!!
>>> On Wed, Jun 16, 2010 at 6:05 PM, Anders Carlsson 
> wrote:
>>>> Also, PlatformMechanism is a Factory, and should be named accordingly.
>>>> Or maybe it's a Source of clients/mechanisms.
>>> Good point, it is a factory.
>>> Is it a factory? If so, I'd expect it to return PassOwnPtrs rather than
>>> *'s. With *'s I'd expect the class to retain ownership (and destroy
>>> them when it's destroyed).
>> Currently I just called the class PlatformPolicies. It is kind of a factory
>> but it will only create singletons that are never intended to be
>> destroyed.
> "Subsystems" might also be a term to consider, although I'm not sure if it fits
> better than other suggested names.

I think I saw strategy go by- the important word was "runtime"- if you were built for
Windoze and you are running on a Mac you better do some quick thinking. Normally
I use this for anything that looks at a problem before deciding what kind of impl to return.
I had been citing FFTW but apparently that has something called a planner, not a strategy.

AFAIK, this is largely a build time issue with not a lot of thinking going on a runtime.

I guess the point of a name is to give reader a clue but after some reflection
I started to think that structured comment conventions may not be a bad idea.

> _______________________________________________
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
Hotmail is redefining busy with tools for the New Busy. Get more from your inbox.

More information about the webkit-dev mailing list