[webkit-dev] A proposal for "Platform Mechanisms"
jpetso at gmx.at
Sat Jun 19 08:35:28 PDT 2010
On June 18, 2010, Anders Carlsson wrote:
> On Jun 17, 2010, at 2:04 PM, Jeremy Orlow wrote:
> > Overall, looks great!!
> > On Wed, Jun 16, 2010 at 6:05 PM, Anders Carlsson <andersca at apple.com>
> > > Also, PlatformMechanism is a Factory, and should be named accordingly.
> > > Or maybe it's a Source of clients/mechanisms.
> > Good point, it is a factory.
> > Is it a factory? If so, I'd expect it to return PassOwnPtrs rather than
> > *'s. With *'s I'd expect the class to retain ownership (and destroy
> > them when it's destroyed).
> Currently I just called the class PlatformPolicies. It is kind of a factory
> but it will only create singletons that are never intended to be
"Subsystems" might also be a term to consider, although I'm not sure if it fits
better than other suggested names.
More information about the webkit-dev