[webkit-dev] More thoughts on cleaning up the root directory
mjs at apple.com
Fri Dec 31 04:07:59 PST 2010
On Dec 29, 2010, at 9:35 PM, Adam Barth wrote:
> On Mon, Dec 27, 2010 at 1:28 PM, Adam Barth <abarth at webkit.org> wrote:
>> On Mon, Dec 27, 2010 at 1:25 PM, Darin Adler <darin at apple.com> wrote:
>>> On Dec 27, 2010, at 11:14 AM, Adam Barth wrote:
>>>> On Mon, Dec 27, 2010 at 10:37 AM, Mark Rowe <mrowe at apple.com> wrote:
>>>>> Can someone also elaborate on why "Sources" was chosen as the top-level directory name rather than "Source"? "Source code" is a mass noun so it's unclear why the abbreviated form of "source" would be pluralized in this manner. Referring to source code as "source" appears to be very common, but I've never encountered "sources" used in this manner. It reads very awkwardly to me.
>>>> That's just the name that Darin used in his email proposing the new layout. If folks would prefer Source, now is a good time to make that change because there's only a handful of directories there now.
>>> I like Source better.
> Some further thoughts:
> 1) Xcode seems to use the term "Sources" to describe a collection of
> source files.
> 2) There seems to be something called
> 3) We have a notion of DerivedSources.
> Would using "Sources" be more consistent with these terms?
I'd still keep it singular. I don't think it is a matter of great import either way though.
More information about the webkit-dev